Installation on a M...
 
Notifications
Clear all

Installation on a Macbook with M1/M2 chip or newer

1 Posts
1 Users
1 Reactions
127 Views
(@solvejg)
Active Member
Joined: 2 months ago
Posts: 3
Topic starter  

Hi,

during the installation for MacOS as described on the webpage, I encountered an error with the python installation on the virtual environment: 

Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  - python=3.5

The reason for this problem is that "there's no native build for python below 3.8 for Apple Silicon" (solution from Github

So, if you have the same error that I had, this should help:

Follow the instructions for MacOS until you have installed and initialised Anaconda. Restart your terminal and switch to ayab-desktop-eknitter directory:

cd ayab-desktop-eknitter

Create an "empty" virtual environment:

conda create --name venv 

Activate the virtual environment:

conda activate venv

Use the x86_64 architecture channel(s) (make sure that you are in the correct environment -> (venv) is written at the start of the row):

conda config --env --set subdir osx-64

Install Python and PIP:

conda install python=3.5 pip

 Now continue with the steps from the instruction, go to this section: "update your python environment with required tools".

 


   
Quote