Buttons not working...
 
Notifications
Clear all

Buttons not working properly

5 Posts
2 Users
0 Reactions
58 Views
(@obradoramor)
Active Member
Joined: 3 months ago
Posts: 7
Topic starter  

Hi, I followed all the steps, at first carriage was not recognized so I turned the blue screw and it changed to checked/recognized. Then connected the wifi ok and if I test knit and lace carriages they are recognized, but buttons M R and 1 and 2 are not working properly. If I press once nothing happens, if I keep M or R pressed for 10 seconds sometimes it reacts and displays a different menu but this method is not always working. The 1 and 2 buttons I couldn't manage to make them work at any time, or the symbols (download/toggle) were shown... What can I do?

I made a video but I can't add it here, for it is 200MB

Thank you!


   
Quote
(@obradoramor)
Active Member
Joined: 3 months ago
Posts: 7
Topic starter  

I wanted to update the post but time to edit expired---so I add new testing as a reply...

I tried loading the sample pattern in the eknitter-ayab software and it loads to the km too! although the buttons on the board are still not working or showing the options on the display, the needles were selected ok as the pattern rows...so I guess the row by row transmission works ok... Also tested checking Infinite repeat on the software and it keeps selecting ok

Tried to press CE, Cf and RR but it seems as the pattern is not downloaded they don't work either,

Tried M and R again and sometimes they work immediately but most of the times they don't react, anyway, although the display got stuck in the first menu I still was able to knit and see the progress on the software ok...


   
ReplyQuote
admin-eknitter
(@admin-eknitter)
Member Admin
Joined: 1 year ago
Posts: 16
 

@obradoramor Sorry for the late reply; we are currently on vacation. The buttons are designed to react only upon release; holding them down longer won't have any effect. Please correct me if I misunderstood. From what I gather, your buttons sometimes work, which is indeed unusual. Have you tried cleaning them? Could you also take a close-up photo of the board showing the part associated with the buttons?

Jeanette from eKnitter


   
ReplyQuote
(@obradoramor)
Active Member
Joined: 3 months ago
Posts: 7
Topic starter  

@admin-eknitter 

 

Hello again!

Thank you for your answer! Sorry, I have been recovering from an illness and only yesterday I was able to resume testing the e-knitter.

I disassembled the board to check that there was no dirt on the buttons, and everything was clean.

I have reassembled the board, connected all the cables, and neither the orange and green buttons nor 1 and 2 work. I have made a couple of videos of when I hold down the green button for a while the menu appears, but this does not always work and only did with green button(not orange, 1 or 2).

I have tried the debug option, and this time I do see the options to download and infinite repeats on the display, but when knitting it does not follow the pattern, it only selects the first and last needle constantly. I don't know if once the debug option is selected from the computer, do I have to do anything else to load the pattern on the machine? I had it loaded in ayab and when I activated the option from the computer it appears in the display but the machine does not follow it, and in ayab there is a crazy blinking when I move the carriage.

Is there any other debug option that I can try to solve these problems?

I have also tried resetting and everything remains the same.

The only option that works is Row by Row, which is great, but in my case it is not very useful, since I live in a rural area with unstable internet conection, and if I lose connection I cannot resume. Nor using or RR/CF rows. 

I need help!

 

I am attaching the photos you asked but I'm not sure all of them are loading, andd the videos are more than 10mb so I am giving you a link to google drive.

https://drive.google.com/drive/folders/1QXMcx9kRmei-Czw5K86nGIwV1lSB5Kql?usp=drive_link

Thank you!!!


   
ReplyQuote
(@obradoramor)
Active Member
Joined: 3 months ago
Posts: 7
Topic starter  

UPDATE:

Some hours later: I have been able to download the pattern to the knitting machine!! It worked good for the first test (triangles pattern), RR button and R button started to work whith the pattern downloaded, CF and CR buttons still not working (as well as 1,2, M)... Sorry for the back and forth, I'm going to keep on trying with my own patterns and let you know the advances... I hope it doesn't bother!

Thank you!!


   
ReplyQuote